1日8,000アクセスの国内最大シトリックスコミュニティ

新規トピック作成

  • タイトル
  • ニックネーム
  • メール
  • 本文

記事を 件ずつ表示しています。

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
  10. 10
  11. >

Netscalerへの接続が急に遅くなる

いず 2020/05/25 17:41:39

こんにちは。
連投になってしまいますがアドバイスいただきたく書き込みさせていただきました。


■現在の問題■

・Netscalerへの接続が急に遅くなる

■環境
Windows Server 2012 R2
Netscaler ADC 13.0(Hype-V)


■状況■
・Netscalerのログイン画面が表示されるまで時間がかかることがある(5分くらい)
・上記の状況になっていると、NSIPへの接続でWebコンソールにもアクセスが難しくなる
・Netscalerを再起動すると現象が改善する
・発生頻度が高い(ほぼ毎日出ている)
・問題がない時にログイン画面を表示させると、数秒でログイン画面が表示される
・アクセス過多が原因ではないと考えられる(まだテストでしか接続していないので、1台程度しか繋いでいない)

■現在の改善案■
・毎日Netscalerを再起動する


何が原因なのか判らないので上記以外改善の方法がないのですが、
改善案は検証を始めたところなので、これで改善されるかは正直微妙なところです。

問題が判るようなところや、どこか設定を見るとよいところなど、些細なことでもかまいません。
何か思い当たるところがありましたら、アドバイスいただければ幸いです。
上記へのレスはこちらにどうぞ
  • ニックネーム
  • メール
  • 本文

ネットワークセグメントが異なるNetscalerとADサーバの通信が取れない

いず 2020/05/11 13:54:53

こんにちは。
Netscalerの通信設定についてなのですが、これ以上先に進まなくなったのでアドバイスいただけないでしょうか。



■現在の問題■

・ネットワークセグメントが異なるNetscalerとADサーバの通信が取れない


■環境
Windows Server 2012 R2 (全てのサーバ)
Netscaler ADC 13.0(Hype-V)
 ※認証はADサーバで行う
 ※XenAppは7.18で、StoreFrontはスキップする

------------------------------------------------------------------------
インターネット


-------------------
SW、FW
 (グローバルIPと内部IPの変換はSWで実施)
-------------------


・Hyper-V構築サーバ 内部向きIP:10.10.10.10
               GW:10.10.20.254

・Netscaler ADC      NSIP:10.10.10.100
              SNIP:10.10.10.200
↑   ※NICは4本中、1本はHyper-V構築サーバ用に「10.10.20.254」へ接続
↓    残り3本はHyper-V占有に割り当てており、1本は外部(VIP割当用)、2本は「10.10.20.254」へ接続(NSIP、SNIP割当用)
-------------------
SW、FW            GW:10.10.10.254
               GW:10.10.20.254
-------------------
・XenAppサーバ(StoreFront含) IP:10.10.20.1
・ActiveDirectoryサーバ    IP:10.10.20.2
------------------------------------------------------------------------

・Hyper-V構築サーバは、routeコマンドでGWを指定し、ADサーバの配下に入っている
・Netscalerの認証設定でLDAPをADで指定してテスト認証を行ったところ、
  ADサーバと通信が取れない、ポート389が許可されていない可能性がある旨が表示
・ポート(389)はFWで許可済み
------------------------------------------------------------------------

Windowsと同様、ルートを指定することで対応が出来るのではと考え、ルートを追加設定しています。
現在、Routes→Basicの中にあるのは、以下の内容です。

System→Network→Routes→Basic
 NW      MASK      GW
127.0.0.0  255.0.0.0   127.0.0.1      ←初期値
10.10.10.0  255.255.255.0 10.10.10.100    ←初期値
10.10.20.0  255.255.255.0 10.10.10.254    ←追加分(設定時、他の値は初期値)


ルーティングの設定が足りないのではと思うのですが、何を直せばよいのか判断ができません。
他に何か追加設定があるのでしょうか。
どなたかアドバイスいただけれ幸いです。


■補足■
まだ外部での接続テストなどの段階までいっていないため、現在まだ内部用のNICを1本しか繋いでいない状態です。
内部の設定が問題なければ、同様の手段で外部用のルートを設定を考えています(外部のGWのセグメントも異なるため)。

外部と内部で繋がっているSWやFWも違いますので、Windowsのように、各NICにIPアドレスを割り当てる必要もあるのではないかと思っていますが、現在本件の調査中で分かっていません。
もしこのあたりが影響していましたらご指摘ください。

いず 2020/05/14 19:22:16

こんばんは。

原因が判りました。
ルートの設定は問題ありませんでした。

今回、FWで内部ネットワークとの通信を許可しているIPアドレスに
Hyper-V構築サーバのIPとSNIPを登録して他は通さない設定にしていたのですが、
FWのログを見るとLDAPの登録時のテスト認証の際に使われるIPアドレスがNSIPで
送信されていたため、FWで通信が遮断されている状態でした。
NSIPも許可するようにしましたら、問題なく通信できるようになりました。

通信のログを見ていればもっと早く判明したことを考えると、説明に書かれている通りの
IPを使うわけではなく、あまり盲目的になってはいけないと痛感しました。

お騒がせいたしました。
上記へのレスはこちらにどうぞ
  • ニックネーム
  • メール
  • 本文

changeコマンドについて

初心者 2020/04/23 15:29:27

XenApp6.xの時にはXenAppサーバ―にプリンタドライバを
インストールする際に、以下の順番で行っておりました。
①change△user△/install
②プリンタドライバインストール
③change△user△/execute
XenApp7.15では、以下の手順でXenAPPサーバに
プリンタドライバをインストールしていますが
XenApp6.x同様にchange△user△の対応は必要なのでしょうか?
①XenAPPサーバーにドメイン管理者ユーザーで
 リモートデスクトップ接続
②プリンタドライバインストール
③プリンタ印刷正常

漠然としたご質問で申し訳ありません。
chage△userコマンドの必要性がいまひとつ理解していません。

以上

ぎんぎつね 2020/04/30 12:45:21

導入するモジュールが.msi形式の場合は勝手に判断してくれるので、特に気にする必要はなかったと思います。


上記へのレスはこちらにどうぞ
  • ニックネーム
  • メール
  • 本文

XenApp7.15サーバーのオンライン確認

初心者 2020/04/23 15:36:52

XenApp6.xでは、以下のコマンドが利用できたかと思います。
qfarm△/onlineでオンライン状態の
XenAppサーバの一覧表示
qfarm△/offlineでオフライン状態の
XenAppサーバの一覧表示
XenApp7.15では、qfarmコマンドがなくなりましたが
同じ結果がでるコマンドもしくはCitrixstudioやCitrixStorefrontなどの
管理画面で同様の確認はできますでしょうか?

漠然とした内容で申し訳ありません。

以上、よろしくお願いいたします。

ぎんぎつね 2020/04/30 12:40:21

古いバージョンに詳しくないので実際になにをされたいのか次第ですが、サーバに接続できるかどうかという話であれば、メンテナンスモードが有効か?登録済みの状態か?といったあたりをstudioで確認する方法は有るかと思います。
上記へのレスはこちらにどうぞ
  • ニックネーム
  • メール
  • 本文

Receiverからログオンできない

imasuo 2020/04/28 14:57:53

Receiverからログオンしようとした際にメッセージが表示されます。
「現在、アプリケーションを使用できません。しばらく待ってから再試行するか、
 ヘルプデスクに次の情報を知らせてください。StoreServiceにアクセスできません。」
どのようなことが原因かご教示頂ければと思います。
よろしくお願いいたします。

ぎんぎつね 2020/04/28 20:41:28

ブラウザー経由で接続した場合でも同じように起動できませんか?

一度システム全てのサーバの再起動をおすすめします。
上記へのレスはこちらにどうぞ
  • ニックネーム
  • メール
  • 本文

NetScaler経由のStoreFrontログオンができない

いず 2020/04/24 20:32:20

こんにちは。

過去に同様のスレッドがあったのですが、改善しなかったため何か思い当たる部分があればアドバイスいただきたく書き込ませていただきました。

過去スレッド:https://www.pbsystems.co.jp/bbs/citrix/?id=17683

表題の通り、Netscaler経由でStoreFrontへログオンができません。
流れとしては以下の通りです。
 1.NetscalerのURLでアクセスし、ユーザ名・パスワードを入力し、「ログオン」(この画面はNetscalerのログオン画面ではありません)
 2.「ログオンの有効期限が切れました。続行するには、もう一度ログオンしてください」と表示される
 3.再度ログオンしようとしても同じ画面が表示される

・アクセスのテストを行っているのはIE11で、Citrix Receiverをインストール済みです。
・StoreFrontのURLに直接アクセスした場合はログオンとアプリケーションの起動が行えます。
・テスト環境下のため、Netscalerでルート証明書とサーバ証明書を発行しており、それぞれ接続テストをしている端末にインストール済みです(動作に問題なければ、実際の運用では購入した証明書を利用します)

StoreFrontサーバのイベントログには以下のようなイベントが記録されていました。
-----------------
ゲートウェイを経由するサービス'Store Service'に要求が送信されましたが、このサービスにはゲートウェイが構成されていません。要求の詳細:
X-Citrix-Gateway:
X-Citrix-Via: netscaler.test.jp
X-Citrix-Via-VIP: 192.168.1.80
リモートアドレス:127.0.0.1
X-Forwarded-For: 192.168.1.200,192.168.1.70
-----------------

気になるのは、StoreFrontを再起動すると、詳細タブで表示される「リモートアクセス:有効(VPNトンネルなし)」に設定していたものが「リモートアクセス:無効」に表示が切り替わってしまうことです。
ただ、いくら直しても再起動すると表示だけ変わってしまいます。


過去スレッドで挙げられておりました設定の中では、
・NetscalerにはLDAPの設定済み
・NetscalerのVirtual ServersのVIPで「Enable Authentication」を無効化設定
・StoreFrontの認証設定で「NetScaler Gatewayからのパススルー」を無効化
…として設定しています。

インストール時に参考にしていたサイトは以下です。
https://www.kenta-virtualization.com/entry/2018/09/11/091907
この設定を行ったところ、Netscalerへログインしても再度同じ画面が表示されてしまったため、StoreFrontの設定を変更しました。




うまく説明できず申し訳ないのですが、最終的には、「1回ユーザーとパスワードで認証すればアプリケーションを利用できる」というところなので、ログイン画面がNetscalerでもStoreFrontでも構わないと思っています。
どちらの認証方法でも構いません。
解消のため何かアドバイスをいただけないでしょうか。
よろしくお願いします。

いづ 2020/04/27 14:25:07

取り急ぎNetscaler画面で認証させてStoreFrontのログイン画面はスキップする形で対応することができました。

親ツリーに記載していたサイトの設定でうまくいかなかった原因としては以下のことが原因ではないかなと考えられます。
・Netscalerで設定したシングルサインオンのドメインがStoreFrontとずれがあった
 例 Netscaler :aaa.local
   StoreFront:aaa
・NetscalerでDNSレコードにNetscalerとStoreFrontの両方のレコード追加

 ※Netscalerのセッションプロファイルのうち、Client Experienceの設定をStoreFrontの画面で認証させるために追加設定したところもあるので、そのあたりも影響しているかもしれません



当初の問題の解消にはなっていないので疑問は残るのですが、今回はNetscalerの認証画面で対応を進めようと思います。

もし親スレッドの内容で何か問題点や思い当たるところがあるようでしたら、ご意見いただければ幸いです。
上記へのレスはこちらにどうぞ
  • ニックネーム
  • メール
  • 本文

公開アプリ起動時のエラーについて

りんこ 2020/04/22 14:00:34

下記環境にて【クライアント①】からリモート接続アプリで【クライアント②】に接続し、
【クライアント②】で公開アプリを起動(クリック)した時にエラーメッセージが表示され、
公開アプリが起動できませんでした。

【XenApp環境】
  Windows Server 2016 Standard
  XenApp 7.15 LTSR
  Storefront 3.15
【クライアント①】
  Apple iPad Air2(iPadOS 13.4.1)
  RD Client(リモートデスクトップ接続アプリ)
【クライアント②】
  Windows10 Pro(64bit)
  Citrix Receiver 4.12
  Internet Explorer 11、Microsoft Edge
【エラーメッセージ】
  Citrix 仮想ドライバー(Smard Card)で問題が発生した可能性があります。
  システム管理者に連絡してください。

公開アプリは複数あり、
公開アプリがすべて起動していない時に起きる現象で、
他の公開アプリが起動済みの時は他の公開アプリも起動できます。

環境の都合上、iPadから直接XenApp環境に接続を許可しておりません。

何が原因なのか、「仮想ドライバー(Smard Card)」が何なのか、
まったく分からず困惑しております。
ご存知の方、ご教授いただけますでしょうか。

ぎんぎつね 2020/04/23 07:15:11

Windows10のバージョンが不明ですが、バージョンによってはそもそも未サポートのReceiverもあるので、可能であれば、最新版のworkspaceアプリへのアップデートをおすすめします。

https://docs.citrix.com/ja-jp/citrix-workspace-app-for-windows

また、エラーメッセージで検索すると以下の情報が見つかりましたので参考にしてください。

基本的にエラーメッセージを英語で検索したほうが情報は集めやすいと思います。

https://forum.uipath.com/t/you-might-be-having-an-issue-with-a-citrix-virtual-driver-smartcard-contact-your-system-administrator-for-further-assistance/104384/6

りんこ 2020/04/23 09:20:10

ぎんぎつねさん、ありがとうございます。

> Windows10のバージョンが不明ですが
失礼いたしました。1903です。

現状のままでは解決できないことは分かりました。
ただ利用環境の都合上、すぐに対応できないため、
workspaceアプリへのアップデート、レジストリ追加について、
今後の検討課題とさせていただきます。
上記へのレスはこちらにどうぞ
  • ニックネーム
  • メール
  • 本文

Citrix SSLエラー 4 処理 は 正常 終了 しま した

yamazaki 2020/04/06 06:38:29

「Citrix SSLエラー 4 処理 は 正常 終了 しま した」とポップアップされ、接続出来ません。
クライアント側での対処方法ご存じでしょうか。

■環境
OS:Winows10  Pro
MicrosoftEddge
Citrix Reciever

アプリケーション
 ディスクトップ
  Desktop for SMT

ぎんぎつね 2020/04/06 07:48:55

特定のwindows10のバージョンとの組み合わせで発生するケースがあるようです。

https://support.citrix.com/article/CTX223074?_ga=2.245368583.2088944197.1586126450-1986651965.1584017322
issue5

該当するようであれば、msのパッチが必要のようです。

他の事例もあるようですが、エラーメッセージを英訳して検索された方が、いろいろ事例が見つかるかと思います。
上記へのレスはこちらにどうぞ
  • ニックネーム
  • メール
  • 本文

vCenterサーバの追加

T_T 2020/03/14 12:00:27


XenD7.15でのご質問です。
XenDesktop環境構築済みです。

既存のDelliveryControllerサーバから、
新しい基盤(ESXiのため、別のvCenterサーバで管理)の
仮想マシンのデスクトップ配信ができるようにする予定です。

設定方法がわからず、苦慮しております。

・既存のサイトにvCenterを追加する方法はありますでしょうか。
 vCenter単位でサイトを分ける必要がありますでしょうか。
 
 その場合、Storefront側にする必要がある設定、
 SQLServerのDBを同一にしても問題ないか、など、システムに対する影響範囲、
 利用ユーザ視点での影響範囲に関して、
 情報お持ちの方教えていただけないでしょうか。

よろしくお願いいたします。



ぎんぎつね 2020/03/16 19:43:41

サイトは分けなくても別のVM環境は追加可能かと思います。
以下のURLの接続と「リソースの作成」からvCenterを登録して
VDIで利用するネットワークやストレージを登録すれば
登録したvSphere環境用のカタログが作れます。

https://docs.citrix.com/ja-jp/citrix-virtual-apps-desktops/manage-deployment/connections.html

その他については、聞く前にもう少し具体的な内容で質問をされたほうがいいかと思います。







T_T 2020/03/17 13:06:01

ぎんぎつねさま>
 ありがとうございます。
 サイトをわけなくても追加可能とのことありがとうございます。
 Citrixは勉強中でして、的を得た質問ができず申し訳ありません。
 
 なお、よろしければ以下も教えていただけますと幸いでございます。

・リソースの追加は、「ホスト」-「構成」- 「接続およびリソースの追加」の
  画面のことになりますでしょうか。
 ・カタログは、vCenter単位で作成する必要がありますでしょうか。
 ・同様にデリバリーグループも、vCenter単位で作成する必要がありますでしょうか。


よろしくお願いします。

ぎんぎつね 2020/03/17 13:42:43


・リソースの追加は、「ホスト」-「構成」- 「接続およびリソースの追加」の
  画面のことになりますでしょうか。
     →そうです。リンクに記載がありますのでそちらの手順も確認してみてください。

 ・カタログは、vCenter単位で作成する必要がありますでしょうか。
     →その通りです。ホストの登録では複数のvCenterの環境をグルーピングすることはできないので、それを基に作成するカタログもvCenter毎に作成する必要があります。もう少し補足するとホストの登録はvCenter内のネットワークやストレージ毎の設定なのですが、そのあたりは作成して画面を見てもらったほうが理解がしやすいと思います。MCSを使うのかどうかで必要な設定も変わってくるので。

 ・同様にデリバリーグループも、vCenter単位で作成する必要がありますでしょうか。
   →デリバリーグループはvCenterとは関係ないですね。同じ種類のカタログをまとめるための設定なので、デリバリーグループを作成する際に別環境のvCenter配下でも同じ設定で作成したカタログが複数存在すれば、何台の仮想マシンをデリバリーグループに追加するかが選べます。

新しい環境(vCenter)のカタログの仮想マシンを追加するようなケースであれば、新しいvCenter環境の登録とその環境の仮想マシンのカタログを作成した後、既存のデリバリーグループに追加すれば、異なる環境のvCenter上の仮想マシンを1つのデリバリーグループで管理は可能かと思います。




T_T 2020/03/28 13:04:34

追伸です。

フルクローンの場合、
同一マシンカタログに複数のvCenter管理下の仮想マシンを追加することが可能でした。

ありがとうございました。

よろしくお願いします。

上記へのレスはこちらにどうぞ
  • ニックネーム
  • メール
  • 本文

CitrixReciverが頻繁に切断⇒再接続を繰り返す

しょうた 2020/02/26 08:17:43

HP(Win8.1)PCを30台強使用している環境で、CitrixReciverが頻繁に切断される(利用者からはアプリが頻繁に固まるように感じる)。
HP固有のアプリとの環礁やNICドライバーの省電力設定が影響していると睨み下記を行うが
解消せず。何か心当たりのある方はいないでしょうか?

下記アプリの削除
・HP シュアセンスインストーラー
・HP Velocity
・HP デバイスアクセスマネージャー
・HP クライアントセキュリティマネージャー
・IPM+ Standerd Edition
設定変更
・NICドライバー省電源化の無効化
・ CitrixReceiverをver.4.12⇒4.09にダウン

Reppa 2020/02/27 17:24:12

下記ナレッジが出てきましたがちゃんと検索しましたか?

アドバイザリ: HP Thin Client - バージョン4.11に更新した後、Citrixを起動できません
https://support.hp.com/jp-ja/document/c05973151

しょうた 2020/03/01 11:46:37

現象がまったく違いますが。

しょうた 2020/03/24 12:45:26

2/27のコメントで終わりですか?
こんな板なんの役にも立ちませんね。
あるだけ邪魔ですね。
上記へのレスはこちらにどうぞ
  • ニックネーム
  • メール
  • 本文